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Content

• ecoEditor introduction

• Functions of the ecoEditor (explained directly in the software)

• Exercise – creating new dataset
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Content

• Purpose

• Main features

• Data management in the ecoEditor

• How to start

• Opening the ecoEditor for the 1st time

• All the functions explained directly in the ecoEditor
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Purpose

• The ecoEditor is a freeware used by the ecoinvent Centre for

creating datasets

editing datasets 

reviewing datasets

uploading datasets to the ecoinvent database
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Main features

• Use of the ecoSpold2 format -> new possibilities (parameters, 
variable names, formulas, etc.)

• Undefined multi-output dataset template -> guidance in 
collection of the necessary data

• Build-in help

• Validation of the new dataset -> more than 300 build-in rules 
which ensure the completeness and quality of the dataset 
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Format of the datasets

• Undefined multi-output 
dataset template
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Data management in the ecoEditor

• During installation so called master data are downloaded and 
stored in your computer

• The database is accessed online -> each dataset is downloaded 
separately, the datasets are not stored in your computer unless 
you do so manually 

• The datasets you create in the ecoeditor are not visible to the 
ecoinvent Centre unless you submit them

slide 8 www.ecoinvent.org



How to start

• Download the installation file from 
the ecoinvent webpage and install 
the ecoEditor

• Start the ecoEditor

• Go to Extras -> Account Management 
-> Create account (Update EcoQuery
Account) -> Register Data Provider 
Account + fill in all the information

• Wait for the approval of your 
account by the ecoinvent Centre
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Opening the ecoEditor for the 1st time

• Horizontal menu, classic windows style

• Read about the ecoEditor from the guide, Help -> Show ecoEditor
Introduction

• Go to File -> Update Master Data -> download of the latest master data

• All functions explained directly in ecoeditor …
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Example dataset

• diethyl ether production /GLO
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Symbols, icons, etc.

• The “star”       means, that there is more text, that visible in the current 
view

• “Three dots”          is an icon, which can be clicked on and a new window 
will open

• Text in black was entered by the data provider and can be edited

• Text in grey was generated automatically during submission and cannot be 
edited
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Content

• Regional versus global (GLO) dataset

• Creation of new dataset “From Scratch” in the ecoEditor

• Activity Description and Modelling and Administrative

• Exchanges – new product, amounts, mathematical relation, etc.

• Validation – online, offline

• Creation of new dataset “ From Existing Dataset”

• Review process
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Regional versus global (GLO) datasets
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• Regional datasets cannot be submitted without global (GLO) 

dataset

• Procedure of submitting both regional and GLO datasets:

Manually

Parent-child relationship

Automatic creation of the GLO dataset



Regional versus global (GLO) datasets
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• Manually

When unique data for both the GLO and 
the regional datasets are available

Both the GLO and the regional datasets 
are entered manually

-> simple, less validation errors

-> changes in the future must be done 

manually as well

GLO

REGIONAL



Regional versus global (GLO) datasets
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• Parent-child relationship

When only part of the data are unique in the 
regional dataset and there is a probability they 
will change in the future

GLO dataset is created first and regional 
dataset is created as its child

-> more validation rules

-> all changes in the parent in the future will 

automatically be updated in the child

GLO

REGIONAL



Regional versus global (GLO) datasets
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• Automatic creation of the GLO dataset

The regional dataset(s) is created first and the 
GLO dataset is created using the automatic 
function (because no unique data are available)

The GLO is created as a weighted average (by 
production volume) of the regional datasets

-> save time, less validation errors

-> changes in the future can be done either 

manually or using again this function

GLO

REGIONAL



New Dataset: mango production / IN
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• File -> New -> New Dataset From File -> From Scratch

• Activity Name: mango production

• Geography: India (IN)

• Time Period: 1/1/2008 to 12/31/2013

• File -> Save Dataset As …



Activity Description
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• General Comment:

This dataset represents mango production in India. Yield = 2.5 
t/ha, duration of one cycle: 12 months, etc.

• Included Activities Start:

From maintenance of the orchards after harvest of the previous 
crop.

• Included Activities End:

This activity ends with harvest and storage. 



Activity Description
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• Classifications, System: Value

ISIC rev.4 ecoinvent: 0.125: Growing of other tree and bush fruits 
and nuts

• Technology level:

Current

• Technology, Comment:

Average of all different technologies of mango production in India.



Modelling and Administrative
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• Representativeness, Percent:

75%

• Representativeness, Sampling Procedure:

The data were partially directly from the farmers and combined 
with the information provided by the Association of Indian Mango 
Producers.

• Data Generator and Publication, Person

• Data Generator and Publication, Data Published In



Exchanges – new product 
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• Exchanges -> Add -> Intermediate Exchange -> Create Exchange

• Name: mango

• Variable Name: mango

• Unit: kg

• Classification: 0131: Tropical and subtropical fruits

• Properties:
wet mass = 1kg, dry mass = 0.17kg, 

water in wet mass = wet mass – dry mass = 0.83kg

water content = water in wet mass/dry mass = 4.88kg

carbon content, fossil = 0kg, carbon content, non-fossil = 0.47kg



Mass and carbon compulsory 
properties

Dry mass 
(DM)

Water in Wet 
mass (WWM)

Wet mass (WM)

Water in 
Wet 
mass 

(WWM)

Dry mass 
(DM)

Water content (U)
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• Carbon:
fossil

non-fossil
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Mass and carbon compulsory 
properties



Interrelated properties
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Wet mass 
(WM) Dry mass (DM) Water mass (W) Water content 

(U)

WM WM-W W W/(WM-W)

WM DM WM-DM (WM-DM)/DM

WM WM/(1+U) U*WM/(1+U) U

W+DM DM W W/DM

(W/U)+W W/U W U

(1+U)*DM DM DM*U U



Compulsory properties: units

natural gas, high 
pressure (m3)

palm fruit bunch
(kg)

Wet Mass (WM) 
(kg/unit of the flow)

0.84 1

Dry Mass (DM) (kg/unit
of the flow)

0.84 0.53

Water in Wet Mass 
(WWM) (kg/unit of the
flow)

0 0.47

Carbon content, fossil 
(kg C/kg DM)

0.60 0

Carbon content, non-
fossil (kg C/kg DM)

0 0.59
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Exchanges - amounts
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Type Name Unit Compartment Subcompartment Amount

Reference Product mango kg 1

FromTechnosphere irrigation m3 0

FromTechnosphere phosphate fertiliser, as 
P2O5 kg 0.00746

FromTechnosphere fertilising, by broadcaster ha 0.000418

FromTechnosphere pesticide, unspecified kg 8.82E-05

ToEnvironment Phosphate kg water ground- 2.09E-06

ToEnvironment Pesticides, unspecified kg soil agricultural 0

FromEnvironment Transformation, to 
permanent crop, irrigated m2 natural resource land 0.299

FromEnvironment Transformation, from 
permanent crop, irrigated m2 natural resource land 0.5

FromEnvironment
Occupation, permanent 
crop, irrigated m2*year natural resource land 0.299



Parameters
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Name Variable Name Unit Amount Variable 
Name

Mathematical 
relation Uncertainty Comment

yield, 
agriculture

yield_agriculture metric 
ton/ha 2.4

yield_ 
mango_ 
production

6*0.4 0.0006 
(2,2,2,2,2)

Calculated value based on 
literature. The yield of 
mango production in India 
is 6t/acre (SOURCE). 
1acre=0.4ha.

irrigation 
demand irrigation_demand

m3/ha/
year 728

irrigation_ 
demand_ 
mango 

(100*140*5
2)/1000

0.0006 
(2,2,2,2,2)

Calculated value based on 
literature. 100 
l/plant/week is the 
irrigation requirement of 
one mango plant grown in 
India (SOURCE). 140 
plant/ha is the number of 
plants grown per one 
hectare of land (SOURCE). 
52 weeks/year. 1000 
l/m3.



Exchanges - Mathematical Relation
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Type Name Unit Amount Variable Name Mathematical Relation
Reference Product mango kg 1

FromTechnosphere irrigation m3 1.7472 (yield_mango_production*irrigation_ 
demand_mango)/1000

FromTechnosphere
pesticide, 
unspecified kg 8.82E-05 pesticide_ 

unspecified_input

ToEnvironment Pesticides, 
unspecified kg 8.82E-05 pesticide_ 

unspecified_to_soil pesticide_ unspecified_input

• The amount of pesticide, unspecified released to soil is equal to 

the amount of pesticide, unspecified which enters the activity

• The amount of irrigation needed is calculated using parameters



Exchanges –
Uncertainty, Source, Comment
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Type Name Unit Uncertainty Source Comment
Reference Product mango kg

FromTechnosphere irrigation m3

0.0006 (2,2,2,2,2)

Calculated based on 
literature data (SOURCE). 
See the mathematical 
relation and parameters 
and their comments.

FromTechnosphere phosphate fertiliser, as P2O5 kg 0.0006 (2,2,2,2,2)

Calculated based on 
literature data (SOURCE).

FromTechnosphere fertilising, by broadcaster ha 0.0006 (2,2,2,2,2)
FromTechnosphere pesticide, unspecified kg 0.0006 (2,2,2,2,2)
ToEnvironment Phosphate kg 0.04 (2,2,2,2,2)
ToEnvironment Pesticides, unspecified kg 0.04 (2,2,2,2,2)

FromEnvironment
Transformation, to permanent 
crop, irrigated m2 0.12 (2,2,2,2,2)

FromEnvironment Transformation, from permanent 
crop, irrigated m2 0.12 (2,2,2,2,2)

FromEnvironment Occupation, permanent crop, 
irrigated m2*year 0.04 (2,2,2,2,2)



Exchanges – Production Volume
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Type Name Unit
Annual Production 

Volume Production Volume Comment

Reference Product mango kg 16.34E9
Literature value (SOURCE) for the year 2010. The 
Indian production represents 42% of the global 
production of mangoes.

• Annual Production Volume (APV) need to be filled only for the Reference 
Product and By-products, if there are some

• APV represent the amount of the reference product produced in a given 

technology and geography

• The unit of the APV is identical with the unit of the reference product



Exchanges – Activity Link
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• When it is clear from where the concrete product comes from

phosphate fertiliser, as P2O5 -> Activity Link -> set to “citric acid production” 
RER, meaning I know the fertilizer I am using comes from this concrete activity; 
and this activity can adapt its production to my needs 

• Modelling challenges

The transport from the market must be included directly in the production 
activity

The amount of phosphate must be lower than what is the activity to which it 
links producing



Validation - offline
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• Dataset is being validated offline against the validation rules which are 

build in the ecoEditor

• File -> Validate Dataset

• Modelling and Administrative, Review, Details

Validation failed with errors: The sum of all land use transformations from 
(0.0.5 m2) must equal the sum of all output transformations to (0.299 m2).

• Modelling and Administrative, Review, Other Details

Balances; dry mass, wet mass, carbon content, etc.



Validation - online
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• Dataset is being validated online against the other datasets already present 

in the database and against the online validation rules

• File -> Submit Datasets for Validation …

• Tasks -> Refresh -> Right Click -> View Validation Results

• Modelling and Administrative, Review, Details

Validation failed with errors: Non-global datasets cannot be uploaded unless a 
global dataset (for the same activity name, time period and macro-economic 
scenario) exists in the database or is uploaded together with the non-global 
dataset. No matching activities found.



Validation - online
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• Dataset is being validated online against the other datasets already present 

in the database and against the online validation rules

• File -> Submit Datasets for Validation …

• Tasks -> Refresh -> Right Click -> View Validation Results

• Modelling and Administrative, Review, Details

Validation failed with errors: Non-global datasets cannot be uploaded unless a 
global dataset (for the same activity name, time period and macro-economic 
scenario) exists in the database or is uploaded together with the non-global 
dataset. No matching activities found.



New Dataset: mango production / CN
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• File -> New -> New Dataset From File -> From Existing Dataset

• Dataset: Open mango production /IN

• Activity Name: mango production

• Geography: China (CN)

• Time Period: 1/1/2008 to 12/31/2013

• File -> Save Dataset As …



Parameters
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Name Variable Name Unit Amount Variable 
Name

Mathematical 
relation Uncertainty Comment

yield, 
agriculture

yield_agriculture metric 
ton/ha 3.2

yield_ 
mango_ 
production

8*0.4 0.0006 
(2,2,2,2,2)

Calculated value based 
on literature. The yield 
of mango production in 
India is 8t/acre 
(SOURCE). 1acre=0.4ha.

irrigation 
demand irrigation_demand

m3/ha/
year 500

irrigation_ 
demand_ 
mango 

(80*120*52)
/1000

0.0006 
(2,2,2,2,2)

Calculated value based 
on literature. 80
l/plant/week is the 
irrigation requirement of 
one mango plant grown 
in India (SOURCE). 120 
plant/ha is the number 
of plants grown per one 
hectare of land 
(SOURCE). 52 
weeks/year. 1000 l/m3.



Exchanges - Mathematical Relation
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Type Name Unit Amount Variable Name Mathematical Relation
Reference Product mango kg 1

FromTechnosphere irrigation m3 1.597 (yield_mango_production*irrigation_ 
demand_mango)/1000

FromTechnosphere
pesticide, 
unspecified kg 8.82E-05 pesticide_ 

unspecified_input

ToEnvironment Pesticides, 
unspecified kg 8.82E-05 pesticide_ 

unspecified_to_soil pesticide_ unspecified_input

• The amount of pesticide, unspecified released to soil is equal to 

the amount of pesticide, unspecified which enters the activity

• The amount of irrigation needed is calculated using parameters



Exchanges - amounts
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Type Name Unit Compartment Subcompartment Amount

Reference Product mango kg 1

FromTechnosphere irrigation m3 1.597

FromTechnosphere phosphate fertiliser, as 
P2O5 kg 0.00746

FromTechnosphere fertilising, by broadcaster ha 0.000418

FromTechnosphere pesticide, unspecified kg 5E-05

ToEnvironment Phosphate kg water ground- 2.09E-06

ToEnvironment Pesticides, unspecified kg soil agricultural 5E-05

FromEnvironment Transformation, to 
permanent crop, irrigated m2 natural resource land 0.299

FromEnvironment Transformation, from 
permanent crop, irrigated m2 natural resource land 0.299

FromEnvironment
Occupation, permanent 
crop, irrigated m2*year natural resource land 0.299



Exchanges – Production Volume
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Type Name Unit
Annual Production 

Volume Production Volume Comment

Reference Product mango kg 4.35E9
Literature value (SOURCE) for the year 2010. The 
Chinese production represents 11% of the global 
production of mangoes.

• Annual Production Volume (APV) need to be filled only for the Reference 
Product and By-products, if there are some

• APV represent the amount of the reference product produced in a given 

technology and geography

• The unit of the APV is identical with the unit of the reference product



New Dataset: mango production / GLO
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• Regional datasets cannot be submitted without global (GLO) dataset

• There are several types of GLO

Original data for the GLO dataset are available -> dataset to be created as 
any other unique dataset, possibility of using parent-child relationship

No original data are available -> dataset to be created using automatic 
function in the ecoeditor (the data provider can choose if he/she wants to 
claim the authorship for this dataset)

• The annual production volume of the global dataset have to be always 

entered



The review process
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• Before the submission to the review, the data provider must:

Make sure that there are no validation errors

Make sure, that most of the validation warnings are justifiable

Reach an agreement with the ecoinvent Centre management, that 
the dataset should be submitted

• File -> Submit Datasets For Review + follow the progress of the 

review in the Tasks sheet
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